We have noticed that you do not have the latest version of the Flash Plug-in.